Prism 2 and Enterprise 5.0 and Unity 2.0 Compatibility

Topics: Prism v2 - Silverlight 2, Prism v2 - Silverlight 3, Prism v2 - WPF 3.5
Mar 21, 2010 at 11:37 PM

I am trying to upgrade a Prism 2 app I have to use the latest Unity and Enterprise Library, but apparently they are not compatiable. It appears that the ObjectBuilder2 class has been consumed by the Unity class and the ExceptionExtensions.RegisterFrameworkExceptionType(typeof(Microsoft.Practices.ObjectBuilder2.BuildFailedException)); does not exist.

Will there be another Prism release that updates the Unity.Extensions to work with the latest Unity and EntLib?

Mar 22, 2010 at 5:08 PM

Hi,

This thread provides some information that might be useful for you as it is related to this subject.

Please, let me know if this helps.

Damian Schenkelman
http://blogs.southworks.net/dschenkelman