Views not being displayed in the Regions

Topics: Prism v4 - Silverlight 4
Jan 9, 2012 at 1:08 PM

Hi,

I have created the small app using Prism V4 on Silverlight 4

I am downloading the modules on demand (By clicking on the hyperlink button). When module download is completed I am using RequestNavigate method of IRegionManager to navigate to module default page. I am not getting any errors as such and module gets loaded successfully. But I can't see the view. I am not able to get it what wrong I am doing.

You can downoad the sample solution from this location (https://skydrive.live.com/embed?cid=E84CFB62692563C4&resid=E84CFB62692563C4%21291&authkey=AMnDOJwE4i1IF_o)

Once it is downloaded use (afzal/afzal) as username and password and click on the Admin link.

Can anyone help ?

Thanks in advance

 

Regards

Developer
Jan 9, 2012 at 8:30 PM
Edited Jan 9, 2012 at 8:33 PM

Hi,

We debugged your application and found that the AdminHomeView view is registered correctly in the MainContentRegion.

On the other hand we found that your MainContentRegion is defined in a Grid inside a BusyIndicator, which uses the NavigationGridStyle style. The problem seems to be in this particular style which sets the Height property with a predefined value and the MainContentRegion is not being shown as the Grid is too small.

To solve this you could try not setting the value of this property in the aforementioned style.

Also you could try defining your MainContentRegion outside the BusyIndicator.

I hope you find this helpful,

Agustin Adami
http://blogs.southworks.net/aadami