can't publish quickstart ModularityWithUnity.Desktop

Topics: Prism v4 - WPF 4
Oct 5, 2012 at 8:41 PM

Hi again, I'm trying to publish using click once a quickstart project (ModularityWithUnity.Desktop) following the directions that appear in the Prism guidelines, but I get 3 warnings that may be causing that the application does not get copied to the traget folder. First, I did build the project  successfully, but when I tried to publish it, I got the following warnings:

Warning 1 Item 'Microsoft.Windows.Installer.3.1' could not be located in 'C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0A\Bootstrapper\'. ModularityWithUnity.Desktop


Warning 2 Item 'Windows Installer 4.5' is required by 'Microsoft .NET Framework 4 Client Profile (x86 and x64)', but was not included. ModularityWithUnity.Desktop


Warning 3 Unable to view published application at http://<machinename>:8080/PrismDeploymentHOL/.  1 1 ModularityWithUnity.Desktop

 

I have a 64 bit machine, and I notice that the target platform of the project is x86. However, when I tried to download the files that supposedly needs the installer told me that the update did not apply for the machine.

Thanks in advance for any help

 

 

Developer
Oct 9, 2012 at 6:13 PM

Hi,

I believe that the cause of this problem could be that you are using Visual Studio 2012, which have the Windows Installer 4.5 package by default. And you are trying to retrieve the 3.1 version which may not be present in the Bootstrapper packages location, hence to avoid the first two warnings for example you could try changing the installation prerequisites, to do this go to the ModularityWithUnity.Desktop WPF project, right-click the project in Solution Explorer, and then click Properties. In the project settings, click the Publish tab and click on the Prerequisites button, there you could select the available Windows Installer version.

Also, for more information on how to add additional Bootstrapper Packages I believe you could find the following article interesting:

Regarding the third warning, I believe this is expected, as mentioned in the WPF Prism Deployment Hands-On Lab:

Depending on the computer you publish to and the security settings, you may get a warning that Visual Studio is unable to view the published application. This simply means it was unable to launch a browser and navigate to the publish location URL. However, the application is not really ready to install yet at this point because you need to add the dynamic modules to the manifests in the next task.

I hope you find this handy,

Agustin Adami
http://blogs.southworks.net/aadami

Oct 9, 2012 at 10:07 PM

Thanks so much Agustin, that did it. After I changed the prerequisites to use the installer provided by VS2012 (i.e. 4.5), I got rid of the

warnings referencing the 3.1 installer, but the .application file did not get created. I believe it was because I do not have a local IIS, and I was

assuming that if I just created the folder I could use the localhost address. I changed the URL ination address to use the regular file system, and the

file got created. Then, after that everything was smooth. How could I use a URL address? I do have windows 7 enterprise but I do not see a local IIS installed.

Is it in a separate component of the installation? Thanks again!

Developer
Oct 10, 2012 at 12:41 PM

Hi,

I'm glad this help you with your problem. Regarding how to install IIS on your local machine I believe you could find the following article from the Official IIS Site helpful:

Best Regards,

Agustin Adami
http://blogs.southworks.net/aadami