The attachable property 'RegionName' was not found in type 'RegionManager'

Dec 15, 2008 at 5:35 AM
Hi Group,

My name is Ram and new to compsite WPF. Downloaded the quick starts and started running the applications. The error posted in discussion name is that prevents me from seeing the actual Shell window in design mode when a region name dependency property is referred. Here are the steps:

1. Create a basic Composite WPF application.
2. Add a namespace xmlns:cal="http://www.codeplex.com/CompositeWPF"
3. Create a region using <ItemsControl Name="MainRegion" cal:RegionManager.RegionName="MainRegion"/>

and the complete xaml code is as follows

<

Window x:Class="Locipaedia.Framework.ShellView"

 

 

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

 

 

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

 

 

xmlns:cal="http://www.codeplex.com/CompositeWPF"

 

 

xmlns:inf="Locipaedia.Common.Infrastructure;assembly=Locipaedia.Common.Infrastructure"

 

 

Title="Locipaedia" Height="600" Width="800">

 

 

<ItemsControl Name="MainRegion" cal:RegionManager.RegionName="MainRegion"/>

 

</

Window>


The application works fine and when run could see the window. But at design time XAML throws an error "The attachable property 'RegionName' was found in type 'RegionManager'.


Any help would greatly appreciated.

Thanks

Thanks Ram

 

Dec 15, 2008 at 2:31 PM
Edited Dec 15, 2008 at 2:32 PM

Hi

                                                                                                                                                                 

You might find useful the answer by Bill Krat in this related thread, where he provides a workaround for a similar problem:

·        

Cider is not working with Region Manager

 

Please let me know if this helps.

 

Damian Schenkelman

http://blogs.southworks.net/dschenkelman

Dec 16, 2008 at 9:32 PM
Thanks a lot Damian. I appreciate your reponse. Interstingly though I could open the same shell in Blend designer and works fine. The work around is good but it bothers me that the issue seems to be sporadic as there is no problem with shell for one of my colleague.

Anyhow thanks once again.
Dec 16, 2008 at 11:33 PM
Thanks for reporting this issue. This should be fixed in the next drop.

Julian Dominguez
http://blogs.southworks.net/jdominguez