WCF service reference cannot be generated with Prism 4.1 and Unity 3

Topics: Prism v4 - WPF 4
Oct 29, 2013 at 8:23 AM
Hello,

I found a problem with Prism 4.1 (for WPF) and the new Version of Unity (3.0.1304.1). I updated my project to .Net Framework 4.5.1 and NuGet Manager updated the other libraries. In this case the new version of Unity will be used (the old one was 2.1.505.2). After the update of Unity Container, the WCF service reference in my project can’t be updated (generated). The WCF generator expect the old version of unity for prism.
I’d like to use the new version of Unity, because my Test project use an AutoMock Library, which need this version of unity…

Best regards
Marian
Developer
Oct 29, 2013 at 5:11 PM
Hello Marian,

As a starting point, please check that you are using the Prism for .NET 4.5 version which you can find in the following one:
I believe this version is not available in the NuGet Gallery.

If the Prism version is correct, then you problem might be related to the one described in the following thread:
I hope this helps,

Damian Cherubini
http://blogs.southworks.net/dcherubini