Targeting Framework 4.5.1

Topics: Prism v4 - WPF 4
Mar 3, 2014 at 1:17 AM
I think I may be missing something.

I've seen some things indicating the 4.2 drop takes advantage of some new features in .net framework 4.5.1. However, the projects in the drop all target framework 4.5 only.

Did I misunderstand?

Thanks in advanced.
Mar 3, 2014 at 5:11 PM
Edited Mar 3, 2014 at 9:30 PM

We did change the prism library to target .NET 4.5 instead of 4.51 so anyone that is still on .NET 4.5 can use the library. The Stock Trader RI and the QuickStarts projects are 4.51 which includes a reference to the Prism library for .NET 4.5.

Is there an issue with targeting .NET 4.5 instead of 4.51? We are not using new capabilities of .NET 4.51 so we wanted to ensure it works for more developers
Marked as answer by BrianInKC on 3/3/2014 at 11:09 AM
Mar 3, 2014 at 6:09 PM

Thank you very much for the reply. Both here and your blog. :)

No, there is no issue. I had seen it mentioned in a few places, including your blog. The previous version targeted 4.5.1 I just wanted to be sure I pulled the right source and that I wasn't missing something when I pulled the newest.

Thanks again.