prism5 'Microsoft.Practices.Prism.Interactivity' is built with an older version of the Blend SDK

Topics: Prism v4 - WPF 4
Apr 27, 2014 at 5:17 PM
I am using nuget to get the prism libraries,
I do the same to get the blend sdk libraries.
But I get into problems and get the following error :
Error 2 The type 'InteractionRequestTrigger' from assembly 'Microsoft.Practices.Prism.Interactivity' is built with an older version of the Blend SDK, and is not supported in a Windows Presentation Framework 4 project.

Does this not mean that the nuget package of prism5 should be updated using the latest version of the blend SDK ?
Or should I try to find the right version of the blend sdk libraries myself ?
Or should I build all the prism libraries myself using the latest blend sdk ?
Coordinator
Apr 28, 2014 at 6:10 AM
stuyckp,

What version of Blend are you using and can you provide a link to where you go it? I want to check to ensure we are using the same binaries. Then I can compare it to the version we tested against.

Thanks.

Blaine Wastell
Coordinator
Apr 28, 2014 at 9:41 PM
Stuyckp,

If you use the "Expression.Blend.Sdk" version 1.0.2 nuget package, that should get you the right version of the Blend SDK.

Thanks,
-Francis