Quickstart Errors - 'Unspecified Error'

Topics: Prism v2 - Silverlight 2
May 7, 2009 at 11:30 PM
I am going through the DefiningModulesInCode quickstart (http://msdn.microsoft.com/en-us/library/dd490828.aspx) and get a number of errors (42, actually - could this be the answer??) ;-)

At any rate, things start to go wrong with the following Warning:
Warning 1 The file 'Mocks\Modules\RemoteModules.xap' could not be added to the project.  Cannot add a link to the file C:\Development\Silverlight\CAL\Silverlight\Composite.Tests\Mocks\Modules\RemoteModules.xap. This file is within the project directory tree. Composite.Silverlight.Tests

Then I get 42 errors that all follow the same pattern:
Error 2 Source file 'C:\Development\Silverlight\CAL\Desktop\Composite.Presentation.Tests\Regions\Behaviors\SyncRegionContextWithHostBehaviorFixture.cs' could not be opened ('Unspecified error ') Composite.Presentation.Desktop.Tests

Is anyone else having these problems?  The files all exist and the linker has been downloaded and installed as well.

Any wisdom on this would be greatly appreciated.
May 8, 2009 at 9:20 PM



The warning about the RemoteModules.xap file you mention is normal and harmless. It appears in all quickstarts as a warning but it shouldn't affect compilation and running the application.


I tried to reproduce the error you mentioned and got exactly the same compilation error when I removed the reading permissions over the files (the ones in the InstallationDir\CAL\Desktop\Composite.Presentation.Tests\ subfolders) . The strange thing is that for this error to appear you should have reading permissions over the project file (Composite.Presentation.Desktop.Tests.csproj), but not over the code files. Otherwise the error would be different.


Hope it helps!


Matias Bonaventura


May 9, 2009 at 10:42 AM
Edited May 9, 2009 at 10:45 AM

I dont think you have VS2008 testing support installed. There are two things you could do -

Install testing support via VS 2008 setup.

OR remove all testing projects from this solution.  This should help you in getting started as you would be able to compile and run this quick start.

May 12, 2009 at 6:32 PM

Thanks Matias and Winrunner for replying.  And apologies for the dilatory response.

Just a clarification:  I am receiving 42 errors - not warnings.

I first checked properties in InstallationDir\CAL\Desktop\Composite.Presentation.Tests\ and the child directories and Read Only is unset.  So, this was not the cause.

I then checked to ensure I had Team Developer and Tester Tools - and I do indeed have Performance Tools, Code Analysis Tools and Testing Tools installed.

Finally, I tried unloading the following six projects and now the solution compiles.



While this is more of a band-aid than anything else I can at least run the solution.  If anyone has any wisdom on why this occurs even though I have Testing Tools installed I would greatly appreciate hearing it.


All the best,


- Rich

Sep 9, 2009 at 9:34 AM
Tournesol143 wrote:

Thanks Matias and Winrunner for replying.  And apologies for the dilatory response.

Just a clarification:  I am receiving 42 errors - not warnings

 This happens when the xap files cannot be build.

There's a batch file which will executed during build:


Because I have no script module attached to the .vbs extension, the builds fails.

So I added the following option to the three lines (31-33) after "REM Add the 2 DLLs and the manifest to a Zip file":

cscript  /E:vbscript /nologo AddToZip.vbs "%CD%\RemoteModules.temp.zip" "%CD%\AppManifest.xaml"

It's compiling now.