Is the current drop compatible with SL3?

Topics: Prism v2 - Silverlight 2
May 18, 2009 at 7:01 PM

I'm currently going through the docs and getting ready to use it in SL3 beta. Is the current download compatible with SL3 beta?

Thanks!
..Ben

May 18, 2009 at 7:47 PM

Hi Ben,

 

Yes, Prism v2 is compatible with SL3!

Please keep in mind that as Silverlight 3 is in beta version, it is not officially supported. However, features that previously existed in Silverlight 2 should work with Prism-v2 & Silverlight 3. New features might not work out-of-the-box.  

 

For instance Silverlight 3 navigation with Remote Modularity does not work. You can read more about that below:

·         How To: Integrate a Prism v2 application with the Silverlight 3 Navigation Framework

·         Prism 2 & Silverlight 3 Beta Navigation

 

On the other side, I created a sample application that used a Silverlight 3 Data Form and added a command with an attached behavior to it:

·         Commands with Attached Behavior for Silverlight 3 DataForm

 

Please let me know if this helps.

 

Damian Schenkelman

http://blogs.southworks.net/dschenkelman

May 18, 2009 at 7:54 PM

Thank you Damian for quick response. It greatly appreciated.

I'll look at the resources you provided and keep you posted. Are the DLLs that come with the current download are also usable with SL3 or do we need to download and rebuild the DLLs?

Since the SL3 RTW won't be too far from going live (I hope), are you guys working on the porting of Prism 2 for SL3? I really want to stick to this pattern and move on with it!

Thank you once again!
..Ben