StockTraderRI Unity Version?...

Sep 3, 2015 at 5:55 PM
Hi,

Is there a Unity version of StockTraderRI under Prism 5.0 anywhere, if not will the V2.2 work under 5?
Sep 3, 2015 at 6:54 PM
Nope. RI was only built with MEF in 4.0, and there were significant refactorings across the app from the 2.2 version.
Sep 3, 2015 at 11:30 PM
Ok thanks, but the concept of V2.2 as far as using Unity in 5.0 will work correct? I have it upgraded from VS2008 to 2015 running successfully.
Sep 4, 2015 at 10:17 AM
Yes, of course. Unity is fully supported in Prism 5 (and Prism 6 which we expect to release next week for WPF and UWP - http://github.com/PrismLibrary/Prism). And I don't think we introduced any breaking changes in Prism 4 or 5 that would make the StockTrader code from Prism 2.2 stop working.
Sep 6, 2015 at 2:32 AM
Edited Sep 6, 2015 at 2:44 AM
Thanks again! And I Just took a look at the examples of version 6 and it looks great! Will download it and do some poking around. I feel Windows 10 is the best OS yet.

This is awesome:
ViewModelLocationProvider.Register(typeof(MainPage).ToString(), () => new MainPageViewModel(_dataRepository, NavigationService));