1
Vote

Microsoft.Practices.Prism.PubSubEvents.dll causes compiler warning in .NET 4.5 projects

description

Hi!

Microsoft.Practices.Prism.PubSubEvents.dll causes a compiler warning in my project, because it depends on System and System.Core with Version 2.0.5.0:
There was a conflict between "System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" and "System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes".
"System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" was chosen because it was primary and "System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes" was not.
 References which depend on "System.Core, Version=4.0.0.0, Culture=neutral, 
[...]
References which depend on "System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes" [].
[...]\bin\Debug\Microsoft.Practices.Prism.PubSubEvents.dll
Can you fix this, please?

comments

luetm wrote Jul 28, 2015 at 9:53 AM

Issue still here in VS 2015. Anyone home?